cve.bz

CVE-2022-23564

6.5 mediumEPSS 0.5%

Medium (6.5) in google tensorflow. EPSS 0.5% chance of exploitation in the next 30 days. Fixed in tensorflow 2.5.3, 2.6.3, 2.7.1.

Tensorflow is an Open Source Machine Learning Framework. When decoding a resource handle tensor from protobuf, a TensorFlow process can encounter cases where a `CHECK` assertion is invalidated based on user controlled arguments. This allows attackers to cause denial of services in TensorFlow processes. The fix will be included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range.

Severity

CVSS 3.1

6.5 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
0.5% chance of exploitation in the next 30 days; higher than 40% of CVEs (scores of 2026-10-31)
CWE
CWE-617
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-8rcj-c8pj-v3m3PyPItensorflow<2.5.32.5.3
GHSA-8rcj-c8pj-v3m3PyPItensorflow>=2.6.0 <2.6.32.6.3
GHSA-8rcj-c8pj-v3m3PyPItensorflow>=2.7.0 <2.7.12.7.1
GHSA-8rcj-c8pj-v3m3PyPItensorflow-cpu<2.5.32.5.3
GHSA-8rcj-c8pj-v3m3PyPItensorflow-cpu>=2.6.0 <2.6.32.6.3
GHSA-8rcj-c8pj-v3m3PyPItensorflow-cpu>=2.7.0 <2.7.12.7.1
GHSA-8rcj-c8pj-v3m3PyPItensorflow-gpu<2.5.32.5.3
GHSA-8rcj-c8pj-v3m3PyPItensorflow-gpu>=2.6.0 <2.6.32.6.3
GHSA-8rcj-c8pj-v3m3PyPItensorflow-gpu>=2.7.0 <2.7.12.7.1
PYSEC-2022-128PyPItensorflow-gpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2022-73PyPItensorflow-cpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2026-3139PyPItensorflow<2.5.3
>=2.6.0 <2.6.3
>=2.7.0 <2.7.1
2.5.3, 2.6.3, 2.7.1

References

Check your stackJSON