cve.bz

CVE-2022-23562

8.8 highEPSS 0.6%

High (8.8) in google tensorflow. EPSS 0.6% chance of exploitation in the next 30 days. Fixed in tensorflow 2.5.3, 2.6.3, 2.7.1.

Tensorflow is an Open Source Machine Learning Framework. The implementation of `Range` suffers from integer overflows. These can trigger undefined behavior or, in some scenarios, extremely large allocations. The fix will be included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.6% chance of exploitation in the next 30 days; higher than 47% of CVEs (scores of 2026-10-31)
CWE
CWE-190
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-qx3f-p745-w4hrPyPItensorflow<2.5.32.5.3
GHSA-qx3f-p745-w4hrPyPItensorflow>=2.6.0 <2.6.32.6.3
GHSA-qx3f-p745-w4hrPyPItensorflow>=2.7.0 <2.7.12.7.1
GHSA-qx3f-p745-w4hrPyPItensorflow-cpu<2.5.32.5.3
GHSA-qx3f-p745-w4hrPyPItensorflow-cpu>=2.6.0 <2.6.32.6.3
GHSA-qx3f-p745-w4hrPyPItensorflow-cpu>=2.7.0 <2.7.12.7.1
GHSA-qx3f-p745-w4hrPyPItensorflow-gpu<2.5.32.5.3
GHSA-qx3f-p745-w4hrPyPItensorflow-gpu>=2.6.0 <2.6.32.6.3
GHSA-qx3f-p745-w4hrPyPItensorflow-gpu>=2.7.0 <2.7.12.7.1
PYSEC-2022-126PyPItensorflow-gpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2022-71PyPItensorflow-cpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2026-3232PyPItensorflow<2.5.3
>=2.6.0 <2.6.3
>=2.7.0 <2.7.1
2.5.3, 2.6.3, 2.7.1

References

Check your stackJSON