cve.bz

CVE-2022-23560

8.8 highEPSS 0.8%

High (8.8) in google tensorflow. EPSS 0.8% chance of exploitation in the next 30 days. Fixed in tensorflow 2.5.3, 2.6.3, 2.7.1.

Tensorflow is an Open Source Machine Learning Framework. An attacker can craft a TFLite model that would allow limited reads and writes outside of arrays in TFLite. This exploits missing validation in the conversion from sparse tensors to dense tensors. The fix is included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range. Users are advised to upgrade as soon as possible.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.8% chance of exploitation in the next 30 days; higher than 57% of CVEs (scores of 2026-10-31)
CWEs
CWE-125, CWE-787
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-4hvf-hxvg-f67vPyPItensorflow<2.5.32.5.3
GHSA-4hvf-hxvg-f67vPyPItensorflow>=2.6.0 <2.6.32.6.3
GHSA-4hvf-hxvg-f67vPyPItensorflow>=2.7.0 <2.7.12.7.1
GHSA-4hvf-hxvg-f67vPyPItensorflow-cpu<2.5.32.5.3
GHSA-4hvf-hxvg-f67vPyPItensorflow-cpu>=2.6.0 <2.6.32.6.3
GHSA-4hvf-hxvg-f67vPyPItensorflow-cpu>=2.7.0 <2.7.12.7.1
GHSA-4hvf-hxvg-f67vPyPItensorflow-gpu<2.5.32.5.3
GHSA-4hvf-hxvg-f67vPyPItensorflow-gpu>=2.6.0 <2.6.32.6.3
GHSA-4hvf-hxvg-f67vPyPItensorflow-gpu>=2.7.0 <2.7.12.7.1
PYSEC-2022-124PyPItensorflow-gpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2022-69PyPItensorflow-cpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2026-3099PyPItensorflow<2.5.3
>=2.6.0 <2.6.3
>=2.7.0 <2.7.1
2.5.3, 2.6.3, 2.7.1

References

Check your stackJSON