cve.bz

CVE-2022-23559

8.8 highEPSS 1.2%

High (8.8) in google tensorflow. EPSS 1.2% chance of exploitation in the next 30 days. Fixed in tensorflow 2.5.3, 2.6.3, 2.7.1.

Tensorflow is an Open Source Machine Learning Framework. An attacker can craft a TFLite model that would cause an integer overflow in embedding lookup operations. Both `embedding_size` and `lookup_size` are products of values provided by the user. Hence, a malicious user could trigger overflows in the multiplication. In certain scenarios, this can then result in heap OOB read/write. Users are advised to upgrade to a patched version.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
1.2% chance of exploitation in the next 30 days; higher than 67% of CVEs (scores of 2026-10-31)
CWE
CWE-190
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-98p5-x8x4-c9m5PyPItensorflow<2.5.32.5.3
GHSA-98p5-x8x4-c9m5PyPItensorflow>=2.6.0 <2.6.32.6.3
GHSA-98p5-x8x4-c9m5PyPItensorflow>=2.7.0 <2.7.12.7.1
GHSA-98p5-x8x4-c9m5PyPItensorflow-cpu<2.5.32.5.3
GHSA-98p5-x8x4-c9m5PyPItensorflow-cpu>=2.6.0 <2.6.32.6.3
GHSA-98p5-x8x4-c9m5PyPItensorflow-cpu>=2.7.0 <2.7.12.7.1
GHSA-98p5-x8x4-c9m5PyPItensorflow-gpu<2.5.32.5.3
GHSA-98p5-x8x4-c9m5PyPItensorflow-gpu>=2.6.0 <2.6.32.6.3
GHSA-98p5-x8x4-c9m5PyPItensorflow-gpu>=2.7.0 <2.7.12.7.1
PYSEC-2022-123PyPItensorflow-gpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2022-68PyPItensorflow-cpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2026-3146PyPItensorflow<2.5.3
>=2.6.0 <2.6.3
>=2.7.0 <2.7.1
2.5.3, 2.6.3, 2.7.1

References

Check your stackJSON