cve.bz

CVE-2022-23558

8.8 highEPSS 0.8%

High (8.8) in google tensorflow. EPSS 0.8% chance of exploitation in the next 30 days. Fixed in tensorflow 2.5.3, 2.6.3, 2.7.1.

Tensorflow is an Open Source Machine Learning Framework. An attacker can craft a TFLite model that would cause an integer overflow in `TfLiteIntArrayCreate`. The `TfLiteIntArrayGetSizeInBytes` returns an `int` instead of a `size_t. An attacker can control model inputs such that `computed_size` overflows the size of `int` datatype. The fix will be included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.8% chance of exploitation in the next 30 days; higher than 57% of CVEs (scores of 2026-10-31)
CWE
CWE-190
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-9gwq-6cwj-47h3PyPItensorflow<2.5.32.5.3
GHSA-9gwq-6cwj-47h3PyPItensorflow>=2.6.0 <2.6.32.6.3
GHSA-9gwq-6cwj-47h3PyPItensorflow>=2.7.0 <2.7.12.7.1
GHSA-9gwq-6cwj-47h3PyPItensorflow-cpu<2.5.32.5.3
GHSA-9gwq-6cwj-47h3PyPItensorflow-cpu>=2.6.0 <2.6.32.6.3
GHSA-9gwq-6cwj-47h3PyPItensorflow-cpu>=2.7.0 <2.7.12.7.1
GHSA-9gwq-6cwj-47h3PyPItensorflow-gpu<2.5.32.5.3
GHSA-9gwq-6cwj-47h3PyPItensorflow-gpu>=2.6.0 <2.6.32.6.3
GHSA-9gwq-6cwj-47h3PyPItensorflow-gpu>=2.7.0 <2.7.12.7.1
PYSEC-2022-122PyPItensorflow-gpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2022-67PyPItensorflow-cpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2026-3151PyPItensorflow<2.5.3
>=2.6.0 <2.6.3
>=2.7.0 <2.7.1
2.5.3, 2.6.3, 2.7.1

References

Check your stackJSON