cve.bz

CVE-2022-21727

8.8 highEPSS 0.7%

High (8.8) in google tensorflow. EPSS 0.7% chance of exploitation in the next 30 days. Fixed in tensorflow 2.5.3, 2.6.3, 2.7.1.

Tensorflow is an Open Source Machine Learning Framework. The implementation of shape inference for `Dequantize` is vulnerable to an integer overflow weakness. The `axis` argument can be `-1` (the default value for the optional argument) or any other positive value at most the number of dimensions of the input. Unfortunately, the upper bound is not checked, and, since the code computes `axis + 1`, an attacker can trigger an integer overflow. The fix will be included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.7% chance of exploitation in the next 30 days; higher than 51% of CVEs (scores of 2026-10-31)
CWE
CWE-190
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-c6fh-56w7-fvjwPyPItensorflow<2.5.32.5.3
GHSA-c6fh-56w7-fvjwPyPItensorflow>=2.6.0 <2.6.32.6.3
GHSA-c6fh-56w7-fvjwPyPItensorflow>=2.7.0 <2.7.12.7.1
GHSA-c6fh-56w7-fvjwPyPItensorflow-cpu<2.5.32.5.3
GHSA-c6fh-56w7-fvjwPyPItensorflow-cpu>=2.6.0 <2.6.32.6.3
GHSA-c6fh-56w7-fvjwPyPItensorflow-cpu>=2.7.0 <2.7.12.7.1
GHSA-c6fh-56w7-fvjwPyPItensorflow-gpu<2.5.32.5.3
GHSA-c6fh-56w7-fvjwPyPItensorflow-gpu>=2.6.0 <2.6.32.6.3
GHSA-c6fh-56w7-fvjwPyPItensorflow-gpu>=2.7.0 <2.7.12.7.1
PYSEC-2022-106PyPItensorflow-gpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2022-51PyPItensorflow-cpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2026-3159PyPItensorflow<2.5.3
>=2.6.0 <2.6.3
>=2.7.0 <2.7.1
2.5.3, 2.6.3, 2.7.1

References

Check your stackJSON