cve.bz

CVE-2022-21726

8.8 highEPSS 0.8%

High (8.8) in google tensorflow. EPSS 0.8% chance of exploitation in the next 30 days. Fixed in tensorflow 2.5.3, 2.6.3, 2.7.1.

Tensorflow is an Open Source Machine Learning Framework. The implementation of `Dequantize` does not fully validate the value of `axis` and can result in heap OOB accesses. The `axis` argument can be `-1` (the default value for the optional argument) or any other positive value at most the number of dimensions of the input. Unfortunately, the upper bound is not checked and this results in reading past the end of the array containing the dimensions of the input tensor. The fix will be included in TensorFlow 2.8.0. We will also cherrypick this commit on TensorFlow 2.7.1, TensorFlow 2.6.3, and TensorFlow 2.5.3, as these are also affected and still in supported range.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.8% chance of exploitation in the next 30 days; higher than 57% of CVEs (scores of 2026-10-31)
CWE
CWE-125
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-23hm-7w47-xw72PyPItensorflow<2.5.32.5.3
GHSA-23hm-7w47-xw72PyPItensorflow>=2.6.0 <2.6.32.6.3
GHSA-23hm-7w47-xw72PyPItensorflow>=2.7.0 <2.7.12.7.1
GHSA-23hm-7w47-xw72PyPItensorflow-cpu<2.5.32.5.3
GHSA-23hm-7w47-xw72PyPItensorflow-cpu>=2.6.0 <2.6.32.6.3
GHSA-23hm-7w47-xw72PyPItensorflow-cpu>=2.7.0 <2.7.12.7.1
GHSA-23hm-7w47-xw72PyPItensorflow-gpu<2.5.32.5.3
GHSA-23hm-7w47-xw72PyPItensorflow-gpu>=2.6.0 <2.6.32.6.3
GHSA-23hm-7w47-xw72PyPItensorflow-gpu>=2.7.0 <2.7.12.7.1
PYSEC-2022-105PyPItensorflow-gpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2022-50PyPItensorflow-cpu<2.5.3
>=2.6.0 <2.6.3
2.5.3, 2.6.3
PYSEC-2026-3082PyPItensorflow<2.5.3
>=2.6.0 <2.6.3
>=2.7.0 <2.7.1
2.5.3, 2.6.3, 2.7.1

References

Check your stackJSON