cve.bz

CVE-2022-1941

7.5 highEPSS 1.5%

High (7.5). EPSS 1.5% chance of exploitation in the next 30 days. Fixed in protobuf 3.18.3, 3.19.5, 3.20.2.

A parsing vulnerability for the MessageSet type in the ProtocolBuffers versions prior to and including 3.16.1, 3.17.3, 3.18.2, 3.19.4, 3.20.1 and 3.21.5 for protobuf-cpp, and versions prior to and including 3.16.1, 3.17.3, 3.18.2, 3.19.4, 3.20.1 and 4.21.5 for protobuf-python can lead to out of memory failures. A specially crafted message with multiple key-value per elements creates parsing issues, and can lead to a Denial of Service against services receiving unsanitized input. We recommend upgrading to versions 3.18.3, 3.19.5, 3.20.2, 3.21.6 for protobuf-cpp and 3.18.3, 3.19.5, 3.20.2, 4.21.6 for protobuf-python. Versions for 3.16 and 3.17 are no longer updated.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
1.5% chance of exploitation in the next 30 days; higher than 74% of CVEs (scores of 2026-10-31)
CWE
CWE-1286
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-8gq9-2x98-w8hfPyPIprotobuf<3.18.33.18.3
GHSA-8gq9-2x98-w8hfPyPIprotobuf>=3.19.0 <3.19.53.19.5
GHSA-8gq9-2x98-w8hfPyPIprotobuf>=3.20.0 <3.20.23.20.2
GHSA-8gq9-2x98-w8hfPyPIprotobuf>=4.0.0 <4.21.64.21.6
PYSEC-2026-899PyPIprotobuf<3.18.3
>=3.19.0 <3.19.5
>=3.20.0 <3.20.2
>=4.0.0 <4.21.6
3.18.3, 3.19.5, 3.20.2, 4.21.6

References

Check your stackJSON