cve.bz

CVE-2021-41264

9.8 criticalEPSS 1.5%

Critical (9.8) in openzeppelin contracts. EPSS 1.5% chance of exploitation in the next 30 days. Fixed in @openzeppelin/contracts 4.3.2.

OpenZeppelin Contracts is a library for smart contract development. In affected versions upgradeable contracts using `UUPSUpgradeable` may be vulnerable to an attack affecting uninitialized implementation contracts. A fix is included in version 4.3.2 of `@openzeppelin/contracts` and `@openzeppelin/contracts-upgradeable`. For users unable to upgrade; initialize implementation contracts using `UUPSUpgradeable` by invoking the initializer function (usually called `initialize`). An example is provided [in the forum](https://forum.openzeppelin.com/t/security-advisory-initialize-uups-implementation-contracts/15301).

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
1.5% chance of exploitation in the next 30 days; higher than 74% of CVEs (scores of 2026-10-31)
CWE
CWE-665
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-5vp3-v4hc-gx76npm@openzeppelin/contracts>=4.1.0 <4.3.24.3.2
GHSA-5vp3-v4hc-gx76npm@openzeppelin/contracts-upgradeable>=4.1.0 <4.3.24.3.2

References

Check your stackJSON