cve.bz

CVE-2021-41228

7.8 highEPSS 0.2%

High (7.8) in google tensorflow. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in tensorflow 2.4.4, 2.5.2, 2.6.1.

TensorFlow is an open source platform for machine learning. In affected versions TensorFlow's `saved_model_cli` tool is vulnerable to a code injection as it calls `eval` on user supplied strings. This can be used by attackers to run arbitrary code on the plaform where the CLI tool runs. However, given that the tool is always run manually, the impact of this is not severe. We have patched this by adding a `safe` flag which defaults to `True` and an explicit warning for users. The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.

Severity

CVSS 3.1

7.8 high
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 12% of CVEs (scores of 2026-10-31)
CWEs
CWE-94, CWE-78
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-3rcw-9p9x-582vPyPItensorflow>=2.5.0 <2.5.22.5.2
GHSA-3rcw-9p9x-582vPyPItensorflow<2.4.42.4.4
GHSA-3rcw-9p9x-582vPyPItensorflow>=2.6.0 <2.6.12.6.1
GHSA-3rcw-9p9x-582vPyPItensorflow-cpu>=2.5.0 <2.5.22.5.2
GHSA-3rcw-9p9x-582vPyPItensorflow-cpu<2.4.42.4.4
GHSA-3rcw-9p9x-582vPyPItensorflow-cpu>=2.6.0 <2.6.12.6.1
GHSA-3rcw-9p9x-582vPyPItensorflow-gpu>=2.5.0 <2.5.22.5.2
GHSA-3rcw-9p9x-582vPyPItensorflow-gpu<2.4.42.4.4
GHSA-3rcw-9p9x-582vPyPItensorflow-gpu>=2.6.0 <2.6.12.6.1
PYSEC-2021-420PyPItensorflow<2.4.4
>=2.5.0 <2.5.2
>=2.6.0 <2.6.1
>=2.7.0rc0 <2.7.0
2.4.4, 2.5.2, 2.6.1, 2.7.0
PYSEC-2021-637PyPItensorflow-cpu<2.4.4
>=2.5.0 <2.5.2
>=2.6.0 <2.6.1
>=2.7.0rc0 <2.7.0
2.4.4, 2.5.2, 2.6.1, 2.7.0
PYSEC-2021-835PyPItensorflow-gpu<2.4.4
>=2.5.0 <2.5.2
>=2.6.0 <2.6.1
>=2.7.0rc0 <2.7.0
2.4.4, 2.5.2, 2.6.1, 2.7.0

References

Check your stackJSON