cve.bz

CVE-2021-41226

7.1 highEPSS 0.2%

High (7.1) in google tensorflow. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in tensorflow 2.4.4, 2.5.2, 2.6.1.

TensorFlow is an open source platform for machine learning. In affected versions the implementation of `SparseBinCount` is vulnerable to a heap OOB access. This is because of missing validation between the elements of the `values` argument and the shape of the sparse output. The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.

Severity

CVSS 3.1

7.1 high
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 10% of CVEs (scores of 2026-10-31)
CWE
CWE-125
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-374m-jm66-3vj8PyPItensorflow>=2.6.0 <2.6.12.6.1
GHSA-374m-jm66-3vj8PyPItensorflow>=2.5.0 <2.5.22.5.2
GHSA-374m-jm66-3vj8PyPItensorflow<2.4.42.4.4
GHSA-374m-jm66-3vj8PyPItensorflow-cpu>=2.6.0 <2.6.12.6.1
GHSA-374m-jm66-3vj8PyPItensorflow-cpu>=2.5.0 <2.5.22.5.2
GHSA-374m-jm66-3vj8PyPItensorflow-cpu<2.4.42.4.4
GHSA-374m-jm66-3vj8PyPItensorflow-gpu>=2.6.0 <2.6.12.6.1
GHSA-374m-jm66-3vj8PyPItensorflow-gpu>=2.5.0 <2.5.22.5.2
GHSA-374m-jm66-3vj8PyPItensorflow-gpu<2.4.42.4.4
PYSEC-2021-418PyPItensorflow<2.4.4
>=2.5.0 <2.5.2
>=2.6.0 <2.6.1
>=2.7.0rc0 <2.7.0
2.4.4, 2.5.2, 2.6.1, 2.7.0
PYSEC-2021-635PyPItensorflow-cpu<2.4.4
>=2.5.0 <2.5.2
>=2.6.0 <2.6.1
>=2.7.0rc0 <2.7.0
2.4.4, 2.5.2, 2.6.1, 2.7.0
PYSEC-2021-833PyPItensorflow-gpu<2.4.4
>=2.5.0 <2.5.2
>=2.6.0 <2.6.1
>=2.7.0rc0 <2.7.0
2.4.4, 2.5.2, 2.6.1, 2.7.0

References

Check your stackJSON