cve.bz

CVE-2021-41225

7.8 highEPSS 0.2%

High (7.8) in google tensorflow. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in tensorflow 2.4.4, 2.5.2, 2.6.1.

TensorFlow is an open source platform for machine learning. In affected versions TensorFlow's Grappler optimizer has a use of unitialized variable. If the `train_nodes` vector (obtained from the saved model that gets optimized) does not contain a `Dequeue` node, then `dequeue_node` is left unitialized. The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.

Severity

CVSS 3.1

7.8 high
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 9% of CVEs (scores of 2026-10-31)
CWE
CWE-908
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-7r94-xv9v-63jwPyPItensorflow>=2.6.0 <2.6.12.6.1
GHSA-7r94-xv9v-63jwPyPItensorflow>=2.5.0 <2.5.22.5.2
GHSA-7r94-xv9v-63jwPyPItensorflow<2.4.42.4.4
GHSA-7r94-xv9v-63jwPyPItensorflow-cpu>=2.6.0 <2.6.12.6.1
GHSA-7r94-xv9v-63jwPyPItensorflow-cpu>=2.5.0 <2.5.22.5.2
GHSA-7r94-xv9v-63jwPyPItensorflow-cpu<2.4.42.4.4
GHSA-7r94-xv9v-63jwPyPItensorflow-gpu>=2.6.0 <2.6.12.6.1
GHSA-7r94-xv9v-63jwPyPItensorflow-gpu>=2.5.0 <2.5.22.5.2
GHSA-7r94-xv9v-63jwPyPItensorflow-gpu<2.4.42.4.4
PYSEC-2021-417PyPItensorflow<2.4.4
>=2.5.0 <2.5.2
>=2.6.0 <2.6.1
>=2.7.0rc0 <2.7.0
2.4.4, 2.5.2, 2.6.1, 2.7.0
PYSEC-2021-634PyPItensorflow-cpu<2.4.4
>=2.5.0 <2.5.2
>=2.6.0 <2.6.1
>=2.7.0rc0 <2.7.0
2.4.4, 2.5.2, 2.6.1, 2.7.0
PYSEC-2021-832PyPItensorflow-gpu<2.4.4
>=2.5.0 <2.5.2
>=2.6.0 <2.6.1
>=2.7.0rc0 <2.7.0
2.4.4, 2.5.2, 2.6.1, 2.7.0

References

Check your stackJSON