cve.bz

CVE-2021-41221

7.8 highEPSS 0.2%

High (7.8) in google tensorflow. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in tensorflow 2.4.4, 2.5.2, 2.6.1.

TensorFlow is an open source platform for machine learning. In affected versions the shape inference code for the `Cudnn*` operations in TensorFlow can be tricked into accessing invalid memory, via a heap buffer overflow. This occurs because the ranks of the `input`, `input_h` and `input_c` parameters are not validated, but code assumes they have certain values. The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.

Severity

CVSS 3.1

7.8 high
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 12% of CVEs (scores of 2026-10-31)
CWEs
CWE-787, CWE-120
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-cqv6-3phm-hcwxPyPItensorflow>=2.6.0 <2.6.12.6.1
GHSA-cqv6-3phm-hcwxPyPItensorflow>=2.5.0 <2.5.22.5.2
GHSA-cqv6-3phm-hcwxPyPItensorflow<2.4.42.4.4
GHSA-cqv6-3phm-hcwxPyPItensorflow-cpu>=2.6.0 <2.6.12.6.1
GHSA-cqv6-3phm-hcwxPyPItensorflow-cpu>=2.5.0 <2.5.22.5.2
GHSA-cqv6-3phm-hcwxPyPItensorflow-cpu<2.4.42.4.4
GHSA-cqv6-3phm-hcwxPyPItensorflow-gpu>=2.6.0 <2.6.12.6.1
GHSA-cqv6-3phm-hcwxPyPItensorflow-gpu>=2.5.0 <2.5.22.5.2
GHSA-cqv6-3phm-hcwxPyPItensorflow-gpu<2.4.42.4.4
PYSEC-2021-413PyPItensorflow<2.4.4
>=2.5.0 <2.5.2
>=2.6.0 <2.6.1
>=2.7.0rc0 <2.7.0
2.4.4, 2.5.2, 2.6.1, 2.7.0
PYSEC-2021-630PyPItensorflow-cpu<2.4.4
>=2.5.0 <2.5.2
>=2.6.0 <2.6.1
>=2.7.0rc0 <2.7.0
2.4.4, 2.5.2, 2.6.1, 2.7.0
PYSEC-2021-828PyPItensorflow-gpu<2.4.4
>=2.5.0 <2.5.2
>=2.6.0 <2.6.1
>=2.7.0rc0 <2.7.0
2.4.4, 2.5.2, 2.6.1, 2.7.0

References

Check your stackJSON