cve.bz

CVE-2021-41211

7.1 highEPSS 0.2%

High (7.1) in google tensorflow. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in tensorflow 2.6.1, 2.7.0.

TensorFlow is an open source platform for machine learning. In affected versions the shape inference code for `QuantizeV2` can trigger a read outside of bounds of heap allocated array. This occurs whenever `axis` is a negative value less than `-1`. In this case, we are accessing data before the start of a heap buffer. The code allows `axis` to be an optional argument (`s` would contain an `error::NOT_FOUND` error code). Otherwise, it assumes that `axis` is a valid index into the dimensions of the `input` tensor. If `axis` is less than `-1` then this results in a heap OOB read. The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, as this version is the only one that is also affected.

Severity

CVSS 3.1

7.1 high
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 10% of CVEs (scores of 2026-10-31)
CWE
CWE-125
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-cvgx-3v3q-m36cPyPItensorflow>=2.6.0 <2.6.12.6.1
GHSA-cvgx-3v3q-m36cPyPItensorflow-cpu>=2.6.0 <2.6.12.6.1
GHSA-cvgx-3v3q-m36cPyPItensorflow-gpu>=2.6.0 <2.6.12.6.1
PYSEC-2021-403PyPItensorflow>=2.6.0 <2.6.1
>=2.7.0rc0 <2.7.0
2.6.1, 2.7.0
PYSEC-2021-620PyPItensorflow-cpu>=2.6.0 <2.6.1
>=2.7.0rc0 <2.7.0
2.6.1, 2.7.0
PYSEC-2021-818PyPItensorflow-gpu>=2.6.0 <2.6.1
>=2.7.0rc0 <2.7.0
2.6.1, 2.7.0

References

Check your stackJSON