cve.bz

CVE-2021-41203

7.8 highEPSS 0.2%

High (7.8) in google tensorflow. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in tensorflow 2.4.4, 2.5.2, 2.6.1.

TensorFlow is an open source platform for machine learning. In affected versions an attacker can trigger undefined behavior, integer overflows, segfaults and `CHECK`-fail crashes if they can change saved checkpoints from outside of TensorFlow. This is because the checkpoints loading infrastructure is missing validation for invalid file formats. The fixes will be included in TensorFlow 2.7.0. We will also cherrypick these commits on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.

Severity

CVSS 3.1

7.8 high
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 8% of CVEs (scores of 2026-10-31)
CWEs
CWE-190, CWE-345
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-7pxj-m4jf-r6h2PyPItensorflow>=2.6.0 <2.6.12.6.1
GHSA-7pxj-m4jf-r6h2PyPItensorflow>=2.5.0 <2.5.22.5.2
GHSA-7pxj-m4jf-r6h2PyPItensorflow<2.4.42.4.4
GHSA-7pxj-m4jf-r6h2PyPItensorflow-cpu>=2.6.0 <2.6.12.6.1
GHSA-7pxj-m4jf-r6h2PyPItensorflow-cpu>=2.5.0 <2.5.22.5.2
GHSA-7pxj-m4jf-r6h2PyPItensorflow-cpu<2.4.42.4.4
GHSA-7pxj-m4jf-r6h2PyPItensorflow-gpu>=2.6.0 <2.6.12.6.1
GHSA-7pxj-m4jf-r6h2PyPItensorflow-gpu>=2.5.0 <2.5.22.5.2
GHSA-7pxj-m4jf-r6h2PyPItensorflow-gpu<2.4.42.4.4
PYSEC-2021-396PyPItensorflow<2.4.4
>=2.5.0 <2.5.2
>=2.6.0 <2.6.1
>=2.7.0rc0 <2.7.0
2.4.4, 2.5.2, 2.6.1, 2.7.0
PYSEC-2021-613PyPItensorflow-cpu<2.4.4
>=2.5.0 <2.5.2
>=2.6.0 <2.6.1
>=2.7.0rc0 <2.7.0
2.4.4, 2.5.2, 2.6.1, 2.7.0
PYSEC-2021-811PyPItensorflow-gpu<2.4.4
>=2.5.0 <2.5.2
>=2.6.0 <2.6.1
>=2.7.0rc0 <2.7.0
2.4.4, 2.5.2, 2.6.1, 2.7.0

References

Check your stackJSON