cve.bz

CVE-2021-41165

5.4 mediumEPSS 1.6%

Medium (5.4). EPSS 1.6% chance of exploitation in the next 30 days. Fixed in ckeditor4 4.17.0.

CKEditor4 is an open source WYSIWYG HTML editor. In affected version a vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed comments HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.

Severity

CVSS 3.1

5.4 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
1.6% chance of exploitation in the next 30 days; higher than 75% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-7h26-63m7-qhf2npmckeditor4<4.17.04.17.0
GHSA-7h26-63m7-qhf2Packagistckeditor/ckeditor<4.17.04.17.0

References

Check your stackJSON