cve.bz

CVE-2021-40865

9.8 criticalEPSS 64%

Critical (9.8) in apache storm. EPSS 64% chance of exploitation in the next 30 days. Fixed in org.apache.storm:storm 1.2.4, 2.1.1, 2.2.1.

An Unsafe Deserialization vulnerability exists in the worker services of the Apache Storm supervisor server allowing pre-auth Remote Code Execution (RCE). Apache Storm 2.2.x users should upgrade to version 2.2.1 or 2.3.0. Apache Storm 2.1.x users should upgrade to version 2.1.1. Apache Storm 1.x users should upgrade to version 1.2.4

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
64% chance of exploitation in the next 30 days; higher than 99% of CVEs (scores of 2026-10-31)
CWE
CWE-502
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-w729-7633-2fw5Mavenorg.apache.storm:storm>=2.2.0 <2.2.12.2.1
GHSA-w729-7633-2fw5Mavenorg.apache.storm:storm>=1.0.0 <1.2.41.2.4
GHSA-w729-7633-2fw5Mavenorg.apache.storm:storm>=2.1.0 <2.1.12.1.1

References

Check your stackJSON