cve.bz

CVE-2021-3840

8.8 highEPSS 2.0%

High (8.8) in lenovo antilles. EPSS 2.0% chance of exploitation in the next 30 days. Fixed in antilles-tools 1.0.1.

A dependency confusion vulnerability was reported in the Antilles open-source software prior to version 1.0.1 that could allow for remote code execution during installation due to a package listed in requirements.txt not existing in the public package index (PyPi). MITRE classifies this weakness as an Uncontrolled Search Path Element (CWE-427) in which a private package dependency may be replaced by an unauthorized package of the same name published to a well-known public repository such as PyPi. The configuration has been updated to only install components built by Antilles, removing all other public package indexes. Additionally, the antilles-tools dependency has been published to PyPi.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
2.0% chance of exploitation in the next 30 days; higher than 81% of CVEs (scores of 2026-10-31)
CWE
CWE-427
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-hgc3-hp6x-wpgxPyPIantilles-tools<1.0.11.0.1
PYSEC-2021-840PyPIantilles-tools<1.0.11.0.1

References

Check your stackJSON