cve.bz

CVE-2021-38153

5.9 mediumEPSS 6.2%

Medium (5.9). EPSS 6.2% chance of exploitation in the next 30 days. Fixed in org.apache.kafka:kafka_2.12 2.6.3, 2.7.2, 2.8.1.

Some components in Apache Kafka use `Arrays.equals` to validate a password or key, which is vulnerable to timing attacks that make brute force attacks for such credentials more likely to be successful. Users should upgrade to 2.8.1 or higher, or 3.0.0 or higher where this vulnerability has been fixed. The affected versions include Apache Kafka 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.2.0, 2.2.1, 2.2.2, 2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, and 2.8.0.

Severity

CVSS 3.1

5.9 medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
6.2% chance of exploitation in the next 30 days; higher than 93% of CVEs (scores of 2026-10-31)
CWE
CWE-203
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-3j6g-hxx5-3q26Mavenorg.apache.kafka:kafka_2.11>=2.0.0 <=2.4.1no fix published
GHSA-3j6g-hxx5-3q26Mavenorg.apache.kafka:kafka_2.12>=2.0.0 <2.6.32.6.3
GHSA-3j6g-hxx5-3q26Mavenorg.apache.kafka:kafka_2.12>=2.7.0 <2.7.22.7.2
GHSA-3j6g-hxx5-3q26Mavenorg.apache.kafka:kafka_2.12>=2.8.0 <2.8.12.8.1
GHSA-3j6g-hxx5-3q26Mavenorg.apache.kafka:kafka_2.13>=2.4.0 <2.6.32.6.3
GHSA-3j6g-hxx5-3q26Mavenorg.apache.kafka:kafka_2.13>=2.7.0 <2.7.22.7.2
GHSA-3j6g-hxx5-3q26Mavenorg.apache.kafka:kafka_2.13>=2.8.0 <2.8.12.8.1
GHSA-3j6g-hxx5-3q26Mavenorg.apache.kafka:kafka-clients>=2.0.0 <2.6.32.6.3
GHSA-3j6g-hxx5-3q26Mavenorg.apache.kafka:kafka-clients>=2.7.0 <2.7.22.7.2
GHSA-3j6g-hxx5-3q26Mavenorg.apache.kafka:kafka-clients>=2.8.0 <2.8.12.8.1

References

Check your stackJSON