cve.bz

CVE-2021-37680

5.5 mediumEPSS 0.2%

Medium (5.5) in google tensorflow. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in tensorflow 2.3.4, 2.4.3, 2.5.1.

TensorFlow is an end-to-end open source platform for machine learning. In affected versions the implementation of fully connected layers in TFLite is [vulnerable to a division by zero error](https://github.com/tensorflow/tensorflow/blob/460e000de3a83278fb00b61a16d161b1964f15f4/tensorflow/lite/kernels/fully_connected.cc#L226). We have patched the issue in GitHub commit 718721986aa137691ee23f03638867151f74935f. The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.

Severity

CVSS 3.1

5.5 medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 4% of CVEs (scores of 2026-10-31)
CWE
CWE-369
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-cfpj-3q4c-jhvrPyPItensorflow<2.3.42.3.4
GHSA-cfpj-3q4c-jhvrPyPItensorflow>=2.4.0 <2.4.32.4.3
GHSA-cfpj-3q4c-jhvrPyPItensorflow>=2.5.0 <2.5.12.5.1
GHSA-cfpj-3q4c-jhvrPyPItensorflow-cpu<2.3.42.3.4
GHSA-cfpj-3q4c-jhvrPyPItensorflow-cpu>=2.4.0 <2.4.32.4.3
GHSA-cfpj-3q4c-jhvrPyPItensorflow-cpu>=2.5.0 <2.5.12.5.1
GHSA-cfpj-3q4c-jhvrPyPItensorflow-gpu<2.3.42.3.4
GHSA-cfpj-3q4c-jhvrPyPItensorflow-gpu>=2.4.0 <2.4.32.4.3
GHSA-cfpj-3q4c-jhvrPyPItensorflow-gpu>=2.5.0 <2.5.12.5.1
PYSEC-2021-302PyPItensorflow>=2.3.0 <2.3.4
>=2.4.0 <2.4.3
2.3.4, 2.4.3
PYSEC-2021-593PyPItensorflow-cpu>=2.3.0 <2.3.4
>=2.4.0 <2.4.3
2.3.4, 2.4.3
PYSEC-2021-791PyPItensorflow-gpu>=2.3.0 <2.3.4
>=2.4.0 <2.4.3
2.3.4, 2.4.3

References

Check your stackJSON