cve.bz

CVE-2021-37676

7.8 highEPSS 0.2%

High (7.8) in google tensorflow. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in tensorflow 2.3.4, 2.4.3, 2.5.1.

TensorFlow is an end-to-end open source platform for machine learning. In affected versions an attacker can cause undefined behavior via binding a reference to null pointer in `tf.raw_ops.SparseFillEmptyRows`. The shape inference [implementation](https://github.com/tensorflow/tensorflow/blob/460e000de3a83278fb00b61a16d161b1964f15f4/tensorflow/core/ops/sparse_ops.cc#L608-L634) does not validate that the input arguments are not empty tensors. We have patched the issue in GitHub commit 578e634b4f1c1c684d4b4294f9e5281b2133b3ed. The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.

Severity

CVSS 3.1

7.8 high
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 6% of CVEs (scores of 2026-11-01)
CWE
CWE-824
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-v768-w7m9-2vmmPyPItensorflow<2.3.42.3.4
GHSA-v768-w7m9-2vmmPyPItensorflow>=2.4.0 <2.4.32.4.3
GHSA-v768-w7m9-2vmmPyPItensorflow>=2.5.0 <2.5.12.5.1
GHSA-v768-w7m9-2vmmPyPItensorflow-cpu<2.3.42.3.4
GHSA-v768-w7m9-2vmmPyPItensorflow-cpu>=2.4.0 <2.4.32.4.3
GHSA-v768-w7m9-2vmmPyPItensorflow-cpu>=2.5.0 <2.5.12.5.1
GHSA-v768-w7m9-2vmmPyPItensorflow-gpu<2.3.42.3.4
GHSA-v768-w7m9-2vmmPyPItensorflow-gpu>=2.4.0 <2.4.32.4.3
GHSA-v768-w7m9-2vmmPyPItensorflow-gpu>=2.5.0 <2.5.12.5.1
PYSEC-2021-298PyPItensorflow>=2.3.0 <2.3.4
>=2.4.0 <2.4.3
2.3.4, 2.4.3
PYSEC-2021-589PyPItensorflow-cpu>=2.3.0 <2.3.4
>=2.4.0 <2.4.3
2.3.4, 2.4.3
PYSEC-2021-787PyPItensorflow-gpu>=2.3.0 <2.3.4
>=2.4.0 <2.4.3
2.3.4, 2.4.3

References

Check your stackJSON