cve.bz

CVE-2021-37673

5.5 mediumEPSS 0.2%

Medium (5.5) in google tensorflow. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in tensorflow 2.3.4, 2.4.3, 2.5.1.

TensorFlow is an end-to-end open source platform for machine learning. In affected versions an attacker can trigger a denial of service via a `CHECK`-fail in `tf.raw_ops.MapStage`. The [implementation](https://github.com/tensorflow/tensorflow/blob/460e000de3a83278fb00b61a16d161b1964f15f4/tensorflow/core/kernels/map_stage_op.cc#L513) does not check that the `key` input is a valid non-empty tensor. We have patched the issue in GitHub commit d7de67733925de196ec8863a33445b73f9562d1d. The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.

Severity

CVSS 3.1

5.5 medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 4% of CVEs (scores of 2026-10-31)
CWE
CWE-20
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-278g-rq84-9hmgPyPItensorflow<2.3.42.3.4
GHSA-278g-rq84-9hmgPyPItensorflow>=2.4.0 <2.4.32.4.3
GHSA-278g-rq84-9hmgPyPItensorflow>=2.5.0 <2.5.12.5.1
GHSA-278g-rq84-9hmgPyPItensorflow-cpu<2.3.42.3.4
GHSA-278g-rq84-9hmgPyPItensorflow-cpu>=2.4.0 <2.4.32.4.3
GHSA-278g-rq84-9hmgPyPItensorflow-cpu>=2.5.0 <2.5.12.5.1
GHSA-278g-rq84-9hmgPyPItensorflow-gpu<2.3.42.3.4
GHSA-278g-rq84-9hmgPyPItensorflow-gpu>=2.4.0 <2.4.32.4.3
GHSA-278g-rq84-9hmgPyPItensorflow-gpu>=2.5.0 <2.5.12.5.1
PYSEC-2021-295PyPItensorflow>=2.3.0 <2.3.4
>=2.4.0 <2.4.3
2.3.4, 2.4.3
PYSEC-2021-586PyPItensorflow-cpu>=2.3.0 <2.3.4
>=2.4.0 <2.4.3
2.3.4, 2.4.3
PYSEC-2021-784PyPItensorflow-gpu>=2.3.0 <2.3.4
>=2.4.0 <2.4.3
2.3.4, 2.4.3

References

Check your stackJSON