cve.bz

CVE-2021-37671

7.8 highEPSS 0.2%

High (7.8) in google tensorflow. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in tensorflow 2.3.4, 2.4.3, 2.5.1.

TensorFlow is an end-to-end open source platform for machine learning. In affected versions an attacker can cause undefined behavior via binding a reference to null pointer in `tf.raw_ops.Map*` and `tf.raw_ops.OrderedMap*` operations. The [implementation](https://github.com/tensorflow/tensorflow/blob/460e000de3a83278fb00b61a16d161b1964f15f4/tensorflow/core/kernels/map_stage_op.cc#L222-L248) has a check in place to ensure that `indices` is in ascending order, but does not check that `indices` is not empty. We have patched the issue in GitHub commit 532f5c5a547126c634fefd43bbad1dc6417678ac. The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.

Severity

CVSS 3.1

7.8 high
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 6% of CVEs (scores of 2026-10-31)
CWE
CWE-824
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-qr82-2c78-4m8hPyPItensorflow<2.3.42.3.4
GHSA-qr82-2c78-4m8hPyPItensorflow>=2.4.0 <2.4.32.4.3
GHSA-qr82-2c78-4m8hPyPItensorflow>=2.5.0 <2.5.12.5.1
GHSA-qr82-2c78-4m8hPyPItensorflow-cpu<2.3.42.3.4
GHSA-qr82-2c78-4m8hPyPItensorflow-cpu>=2.4.0 <2.4.32.4.3
GHSA-qr82-2c78-4m8hPyPItensorflow-cpu>=2.5.0 <2.5.12.5.1
GHSA-qr82-2c78-4m8hPyPItensorflow-gpu<2.3.42.3.4
GHSA-qr82-2c78-4m8hPyPItensorflow-gpu>=2.4.0 <2.4.32.4.3
GHSA-qr82-2c78-4m8hPyPItensorflow-gpu>=2.5.0 <2.5.12.5.1
PYSEC-2021-293PyPItensorflow>=2.3.0 <2.3.4
>=2.4.0 <2.4.3
2.3.4, 2.4.3
PYSEC-2021-584PyPItensorflow-cpu>=2.3.0 <2.3.4
>=2.4.0 <2.4.3
2.3.4, 2.4.3
PYSEC-2021-782PyPItensorflow-gpu>=2.3.0 <2.3.4
>=2.4.0 <2.4.3
2.3.4, 2.4.3

References

Check your stackJSON