cve.bz

CVE-2021-37664

7.1 highEPSS 0.2%

High (7.1) in google tensorflow. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in tensorflow 2.3.4, 2.4.3, 2.5.1.

TensorFlow is an end-to-end open source platform for machine learning. In affected versions an attacker can read from outside of bounds of heap allocated data by sending specially crafted illegal arguments to `BoostedTreesSparseCalculateBestFeatureSplit`. The [implementation](https://github.com/tensorflow/tensorflow/blob/84d053187cb80d975ef2b9684d4b61981bca0c41/tensorflow/core/kernels/boosted_trees/stats_ops.cc) needs to validate that each value in `stats_summary_indices` is in range. We have patched the issue in GitHub commit e84c975313e8e8e38bb2ea118196369c45c51378. The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.

Severity

CVSS 3.1

7.1 high
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 5% of CVEs (scores of 2026-10-31)
CWE
CWE-125
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-r4c4-5fpq-56wgPyPItensorflow<2.3.42.3.4
GHSA-r4c4-5fpq-56wgPyPItensorflow>=2.4.0 <2.4.32.4.3
GHSA-r4c4-5fpq-56wgPyPItensorflow>=2.5.0 <2.5.12.5.1
GHSA-r4c4-5fpq-56wgPyPItensorflow-cpu<2.3.42.3.4
GHSA-r4c4-5fpq-56wgPyPItensorflow-cpu>=2.4.0 <2.4.32.4.3
GHSA-r4c4-5fpq-56wgPyPItensorflow-cpu>=2.5.0 <2.5.12.5.1
GHSA-r4c4-5fpq-56wgPyPItensorflow-gpu<2.3.42.3.4
GHSA-r4c4-5fpq-56wgPyPItensorflow-gpu>=2.4.0 <2.4.32.4.3
GHSA-r4c4-5fpq-56wgPyPItensorflow-gpu>=2.5.0 <2.5.12.5.1
PYSEC-2021-286PyPItensorflow>=2.3.0 <2.3.4
>=2.4.0 <2.4.3
2.3.4, 2.4.3
PYSEC-2021-577PyPItensorflow-cpu>=2.3.0 <2.3.4
>=2.4.0 <2.4.3
2.3.4, 2.4.3
PYSEC-2021-775PyPItensorflow-gpu>=2.3.0 <2.3.4
>=2.4.0 <2.4.3
2.3.4, 2.4.3

References

Check your stackJSON