cve.bz

CVE-2021-37656

7.8 highEPSS 0.2%

High (7.8) in google tensorflow. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in tensorflow 2.3.4, 2.4.3, 2.5.1.

TensorFlow is an end-to-end open source platform for machine learning. In affected versions an attacker can cause undefined behavior via binding a reference to null pointer in `tf.raw_ops.RaggedTensorToSparse`. The [implementation](https://github.com/tensorflow/tensorflow/blob/f24faa153ad31a4b51578f8181d3aaab77a1ddeb/tensorflow/core/kernels/ragged_tensor_to_sparse_kernel.cc#L30) has an incomplete validation of the splits values: it does not check that they are in increasing order. We have patched the issue in GitHub commit 1071f554dbd09f7e101324d366eec5f4fe5a3ece. The fix will be included in TensorFlow 2.6.0. We will also cherrypick this commit on TensorFlow 2.5.1, TensorFlow 2.4.3, and TensorFlow 2.3.4, as these are also affected and still in supported range.

Severity

CVSS 3.1

7.8 high
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 5% of CVEs (scores of 2026-10-31)
CWE
CWE-824
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-4xfp-4pfp-89wgPyPItensorflow<2.3.42.3.4
GHSA-4xfp-4pfp-89wgPyPItensorflow>=2.4.0 <2.4.32.4.3
GHSA-4xfp-4pfp-89wgPyPItensorflow>=2.5.0 <2.5.12.5.1
GHSA-4xfp-4pfp-89wgPyPItensorflow-cpu<2.3.42.3.4
GHSA-4xfp-4pfp-89wgPyPItensorflow-cpu>=2.4.0 <2.4.32.4.3
GHSA-4xfp-4pfp-89wgPyPItensorflow-cpu>=2.5.0 <2.5.12.5.1
GHSA-4xfp-4pfp-89wgPyPItensorflow-gpu<2.3.42.3.4
GHSA-4xfp-4pfp-89wgPyPItensorflow-gpu>=2.4.0 <2.4.32.4.3
GHSA-4xfp-4pfp-89wgPyPItensorflow-gpu>=2.5.0 <2.5.12.5.1
PYSEC-2021-278PyPItensorflow>=2.3.0 <2.3.4
>=2.4.0 <2.4.3
2.3.4, 2.4.3
PYSEC-2021-569PyPItensorflow-cpu>=2.3.0 <2.3.4
>=2.4.0 <2.4.3
2.3.4, 2.4.3
PYSEC-2021-767PyPItensorflow-gpu>=2.3.0 <2.3.4
>=2.4.0 <2.4.3
2.3.4, 2.4.3

References

Check your stackJSON