Critical (9.8) in dragonfly project dragonfly. EPSS 72% chance of exploitation in the next 30 days. Fixed in dragonfly 1.4.0.
An argument injection vulnerability in the Dragonfly gem before 1.4.0 for Ruby allows remote attackers to read and write to arbitrary files via a crafted URL when the verify_url option is disabled. This may lead to code execution. The problem occurs because the generate and process features mishandle use of the ImageMagick convert utility.
Severity
CVSS 3.1
9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
72% chance of exploitation in the next 30 days; higher than 99% of CVEs (scores of 2026-10-31)