cve.bz

CVE-2021-33036

8.8 highEPSS 4.0%

High (8.8) in apache hadoop. EPSS 4.0% chance of exploitation in the next 30 days. Fixed in org.apache.hadoop:hadoop-yarn-server-common 2.10.2, 3.2.3, 3.3.2.

In Apache Hadoop 2.2.0 to 2.10.1, 3.0.0-alpha1 to 3.1.4, 3.2.0 to 3.2.2, and 3.3.0 to 3.3.1, a user who can escalate to yarn user can possibly run arbitrary commands as root user. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
4.0% chance of exploitation in the next 30 days; higher than 90% of CVEs (scores of 2026-10-31)
CWEs
CWE-22, CWE-24, CWE-264
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-58jx-f5rf-qgqfMavenorg.apache.hadoop:hadoop-yarn-server-common>=2.2.0 <2.10.22.10.2
GHSA-58jx-f5rf-qgqfMavenorg.apache.hadoop:hadoop-yarn-server-common>=3.0.0 <3.2.33.2.3
GHSA-58jx-f5rf-qgqfMavenorg.apache.hadoop:hadoop-yarn-server-common>=3.3.0 <3.3.23.3.2

References

Check your stackJSON