cve.bz

CVE-2021-31407

7.5 highEPSS 2.4%

High (7.5) in vaadin. EPSS 2.4% chance of exploitation in the next 30 days. Fixed in com.vaadin:flow-server 2.4.8, 6.0.1.

Vulnerability in OSGi integration in com.vaadin:flow-server versions 1.2.0 through 2.4.7 (Vaadin 12.0.0 through 14.4.9), and 6.0.0 through 6.0.1 (Vaadin 19.0.0) allows attacker to access application classes and resources on the server via crafted HTTP request.

Severity

CVSS 3.1

7.5 high
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
2.4% chance of exploitation in the next 30 days; higher than 83% of CVEs (scores of 2026-10-31)
CWEs
CWE-668, CWE-402
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-25xc-jwfq-39jwMavencom.vaadin:flow-server>=1.2.0 <2.4.82.4.8
GHSA-25xc-jwfq-39jwMavencom.vaadin:flow-server>=6.0.0 <6.0.16.0.1

References

Check your stackJSON