cve.bz

CVE-2021-29619

5.5 mediumEPSS 0.2%

Medium (5.5) in google tensorflow. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in tensorflow 2.1.4, 2.2.3, 2.3.3.

TensorFlow is an end-to-end open source platform for machine learning. Passing invalid arguments (e.g., discovered via fuzzing) to `tf.raw_ops.SparseCountSparseOutput` results in segfault. The fix will be included in TensorFlow 2.5.0. We will also cherrypick this commit on TensorFlow 2.4.2, TensorFlow 2.3.3, TensorFlow 2.2.3 and TensorFlow 2.1.4, as these are also affected and still in supported range.

Severity

CVSS 3.1

5.5 medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 9% of CVEs (scores of 2026-10-31)
CWE
CWE-755
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-wvjw-p9f5-vq28PyPItensorflow<2.1.42.1.4
GHSA-wvjw-p9f5-vq28PyPItensorflow>=2.2.0 <2.2.32.2.3
GHSA-wvjw-p9f5-vq28PyPItensorflow>=2.3.0 <2.3.32.3.3
GHSA-wvjw-p9f5-vq28PyPItensorflow>=2.4.0 <2.4.22.4.2
GHSA-wvjw-p9f5-vq28PyPItensorflow-cpu<2.1.42.1.4
GHSA-wvjw-p9f5-vq28PyPItensorflow-cpu>=2.2.0 <2.2.32.2.3
GHSA-wvjw-p9f5-vq28PyPItensorflow-cpu>=2.3.0 <2.3.32.3.3
GHSA-wvjw-p9f5-vq28PyPItensorflow-cpu>=2.4.0 <2.4.22.4.2
GHSA-wvjw-p9f5-vq28PyPItensorflow-gpu<2.1.42.1.4
GHSA-wvjw-p9f5-vq28PyPItensorflow-gpu>=2.2.0 <2.2.32.2.3
GHSA-wvjw-p9f5-vq28PyPItensorflow-gpu>=2.3.0 <2.3.32.3.3
GHSA-wvjw-p9f5-vq28PyPItensorflow-gpu>=2.4.0 <2.4.22.4.2
PYSEC-2021-256PyPItensorflow<2.1.4
>=2.2.0 <2.2.3
>=2.3.0 <2.3.3
>=2.4.0 <2.4.2
2.1.4, 2.2.3, 2.3.3, 2.4.2
PYSEC-2021-547PyPItensorflow-cpu<2.1.4
>=2.2.0 <2.2.3
>=2.3.0 <2.3.3
>=2.4.0 <2.4.2
2.1.4, 2.2.3, 2.3.3, 2.4.2
PYSEC-2021-745PyPItensorflow-gpu<2.1.4
>=2.2.0 <2.2.3
>=2.3.0 <2.3.3
>=2.4.0 <2.4.2
2.1.4, 2.2.3, 2.3.3, 2.4.2

References

Check your stackJSON