cve.bz

CVE-2021-29613

7.1 highEPSS 0.2%

High (7.1) in google tensorflow. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in tensorflow 2.1.4, 2.2.3, 2.3.3.

TensorFlow is an end-to-end open source platform for machine learning. Incomplete validation in `tf.raw_ops.CTCLoss` allows an attacker to trigger an OOB read from heap. The fix will be included in TensorFlow 2.5.0. We will also cherrypick these commits on TensorFlow 2.4.2, TensorFlow 2.3.3, TensorFlow 2.2.3 and TensorFlow 2.1.4, as these are also affected and still in supported range.

Severity

CVSS 3.1

7.1 high
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 15% of CVEs (scores of 2026-10-31)
CWEs
CWE-125, CWE-665
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-vvg4-vgrv-xfr7PyPItensorflow<2.1.42.1.4
GHSA-vvg4-vgrv-xfr7PyPItensorflow>=2.2.0 <2.2.32.2.3
GHSA-vvg4-vgrv-xfr7PyPItensorflow>=2.3.0 <2.3.32.3.3
GHSA-vvg4-vgrv-xfr7PyPItensorflow>=2.4.0 <2.4.22.4.2
GHSA-vvg4-vgrv-xfr7PyPItensorflow-cpu<2.1.42.1.4
GHSA-vvg4-vgrv-xfr7PyPItensorflow-cpu>=2.2.0 <2.2.32.2.3
GHSA-vvg4-vgrv-xfr7PyPItensorflow-cpu>=2.3.0 <2.3.32.3.3
GHSA-vvg4-vgrv-xfr7PyPItensorflow-cpu>=2.4.0 <2.4.22.4.2
GHSA-vvg4-vgrv-xfr7PyPItensorflow-gpu<2.1.42.1.4
GHSA-vvg4-vgrv-xfr7PyPItensorflow-gpu>=2.2.0 <2.2.32.2.3
GHSA-vvg4-vgrv-xfr7PyPItensorflow-gpu>=2.3.0 <2.3.32.3.3
GHSA-vvg4-vgrv-xfr7PyPItensorflow-gpu>=2.4.0 <2.4.22.4.2
PYSEC-2021-250PyPItensorflow<2.1.4
>=2.2.0 <2.2.3
>=2.3.0 <2.3.3
>=2.4.0 <2.4.2
2.1.4, 2.2.3, 2.3.3, 2.4.2
PYSEC-2021-541PyPItensorflow-cpu<2.1.4
>=2.2.0 <2.2.3
>=2.3.0 <2.3.3
>=2.4.0 <2.4.2
2.1.4, 2.2.3, 2.3.3, 2.4.2
PYSEC-2021-739PyPItensorflow-gpu<2.1.4
>=2.2.0 <2.2.3
>=2.3.0 <2.3.3
>=2.4.0 <2.4.2
2.1.4, 2.2.3, 2.3.3, 2.4.2

References

Check your stackJSON