cve.bz

CVE-2021-29611

5.5 mediumEPSS 0.2%

Medium (5.5) in google tensorflow. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in tensorflow 2.1.4, 2.2.3, 2.3.3.

TensorFlow is an end-to-end open source platform for machine learning. Incomplete validation in `SparseReshape` results in a denial of service based on a `CHECK`-failure. The implementation(https://github.com/tensorflow/tensorflow/blob/e87b51ce05c3eb172065a6ea5f48415854223285/tensorflow/core/kernels/sparse_reshape_op.cc#L40) has no validation that the input arguments specify a valid sparse tensor. The fix will be included in TensorFlow 2.5.0. We will also cherrypick this commit on TensorFlow 2.4.2 and TensorFlow 2.3.3, as these are the only affected versions.

Severity

CVSS 3.1

5.5 medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 10% of CVEs (scores of 2026-10-31)
CWEs
CWE-20, CWE-665
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-9rpc-5v9q-5r7fPyPItensorflow>=2.3.0 <2.3.32.3.3
GHSA-9rpc-5v9q-5r7fPyPItensorflow>=2.4.0 <2.4.22.4.2
GHSA-9rpc-5v9q-5r7fPyPItensorflow-cpu>=2.3.0 <2.3.32.3.3
GHSA-9rpc-5v9q-5r7fPyPItensorflow-cpu>=2.4.0 <2.4.22.4.2
GHSA-9rpc-5v9q-5r7fPyPItensorflow-gpu>=2.3.0 <2.3.32.3.3
GHSA-9rpc-5v9q-5r7fPyPItensorflow-gpu>=2.4.0 <2.4.22.4.2
PYSEC-2021-248PyPItensorflow<2.1.4
>=2.2.0 <2.2.3
>=2.3.0 <2.3.3
>=2.4.0 <2.4.2
2.1.4, 2.2.3, 2.3.3, 2.4.2
PYSEC-2021-539PyPItensorflow-cpu<2.1.4
>=2.2.0 <2.2.3
>=2.3.0 <2.3.3
>=2.4.0 <2.4.2
2.1.4, 2.2.3, 2.3.3, 2.4.2
PYSEC-2021-737PyPItensorflow-gpu<2.1.4
>=2.2.0 <2.2.3
>=2.3.0 <2.3.3
>=2.4.0 <2.4.2
2.1.4, 2.2.3, 2.3.3, 2.4.2

References

Check your stackJSON