cve.bz

CVE-2021-29554

5.5 mediumEPSS 0.2%

Medium (5.5) in google tensorflow. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in tensorflow 2.1.4, 2.2.3, 2.3.3.

TensorFlow is an end-to-end open source platform for machine learning. An attacker can cause a denial of service via a FPE runtime error in `tf.raw_ops.DenseCountSparseOutput`. This is because the implementation(https://github.com/tensorflow/tensorflow/blob/efff014f3b2d8ef6141da30c806faf141297eca1/tensorflow/core/kernels/count_ops.cc#L123-L127) computes a divisor value from user data but does not check that the result is 0 before doing the division. Since `data` is given by the `values` argument, `num_batch_elements` is 0. The fix will be included in TensorFlow 2.5.0. We will also cherrypick this commit on TensorFlow 2.4.2, and TensorFlow 2.3.3, as these are also affected.

Severity

CVSS 3.1

5.5 medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 8% of CVEs (scores of 2026-10-31)
CWE
CWE-369
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-qg48-85hg-mqc5PyPItensorflow>=2.3.0 <2.3.32.3.3
GHSA-qg48-85hg-mqc5PyPItensorflow>=2.4.0 <2.4.22.4.2
GHSA-qg48-85hg-mqc5PyPItensorflow-cpu>=2.3.0 <2.3.32.3.3
GHSA-qg48-85hg-mqc5PyPItensorflow-cpu>=2.4.0 <2.4.22.4.2
GHSA-qg48-85hg-mqc5PyPItensorflow-gpu>=2.3.0 <2.3.32.3.3
GHSA-qg48-85hg-mqc5PyPItensorflow-gpu>=2.4.0 <2.4.22.4.2
PYSEC-2021-191PyPItensorflow<2.1.4
>=2.2.0 <2.2.3
>=2.3.0 <2.3.3
>=2.4.0 <2.4.2
2.1.4, 2.2.3, 2.3.3, 2.4.2
PYSEC-2021-482PyPItensorflow-cpu<2.1.4
>=2.2.0 <2.2.3
>=2.3.0 <2.3.3
>=2.4.0 <2.4.2
2.1.4, 2.2.3, 2.3.3, 2.4.2
PYSEC-2021-680PyPItensorflow-gpu<2.1.4
>=2.2.0 <2.2.3
>=2.3.0 <2.3.3
>=2.4.0 <2.4.2
2.1.4, 2.2.3, 2.3.3, 2.4.2

References

Check your stackJSON