cve.bz

CVE-2021-29512

7.8 highEPSS 0.2%

High (7.8) in google tensorflow. EPSS 0.2% chance of exploitation in the next 30 days. Fixed in tensorflow 2.3.3, 2.4.2.

TensorFlow is an end-to-end open source platform for machine learning. If the `splits` argument of `RaggedBincount` does not specify a valid `SparseTensor`(https://www.tensorflow.org/api_docs/python/tf/sparse/SparseTensor), then an attacker can trigger a heap buffer overflow. This will cause a read from outside the bounds of the `splits` tensor buffer in the implementation of the `RaggedBincount` op(https://github.com/tensorflow/tensorflow/blob/8b677d79167799f71c42fd3fa074476e0295413a/tensorflow/core/kernels/bincount_op.cc#L430-L433). Before the `for` loop, `batch_idx` is set to 0. The user controls the `splits` array, making it contain only one element, 0. Thus, the code in the `while` loop would increment `batch_idx` and then try to read `splits(1)`, which is outside of bounds. The fix will be included in TensorFlow 2.5.0. We will also cherrypick this commit on TensorFlow 2.4.2 and TensorFlow 2.3.3, as these are also affected.

Severity

CVSS 3.1

7.8 high
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.2% chance of exploitation in the next 30 days; higher than 11% of CVEs (scores of 2026-10-31)
CWEs
CWE-787, CWE-120
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-4278-2v5v-65r4PyPItensorflow>=2.3.0 <2.3.32.3.3
GHSA-4278-2v5v-65r4PyPItensorflow>=2.4.0 <2.4.22.4.2
GHSA-4278-2v5v-65r4PyPItensorflow-cpu>=2.3.0 <2.3.32.3.3
GHSA-4278-2v5v-65r4PyPItensorflow-cpu>=2.4.0 <2.4.22.4.2
GHSA-4278-2v5v-65r4PyPItensorflow-gpu>=2.3.0 <2.3.32.3.3
GHSA-4278-2v5v-65r4PyPItensorflow-gpu>=2.4.0 <2.4.22.4.2
PYSEC-2021-149PyPItensorflow>=2.3.0 <2.3.3
>=2.4.0 <2.4.2
2.3.3, 2.4.2
PYSEC-2021-440PyPItensorflow-cpu>=2.3.0 <2.3.3
>=2.4.0 <2.4.2
2.3.3, 2.4.2
PYSEC-2021-638PyPItensorflow-gpu>=2.3.0 <2.3.3
>=2.4.0 <2.4.2
2.3.3, 2.4.2

References

Check your stackJSON