cve.bz

CVE-2021-28918

9.1 criticalEPSS 15%

Critical (9.1) in netmask project netmask. EPSS 15% chance of exploitation in the next 30 days. Fixed in netmask 1.1.0, 2.0.1.

Improper input validation of octal strings in netmask npm package v1.0.6 and below allows unauthenticated remote attackers to perform indeterminate SSRF, RFI, and LFI attacks on many of the dependent packages. A remote unauthenticated attacker can bypass packages relying on netmask to filter IPs and reach critical VPN or LAN hosts.

Severity

CVSS 3.1

9.1 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
15% chance of exploitation in the next 30 days; higher than 96% of CVEs (scores of 2026-10-31)
CWE
CWE-704
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-4c7m-wxvm-r7gcnpmnetmask<1.1.01.1.0
GHSA-pch5-whg9-qr2rnpmnetmask<2.0.12.0.1

References

Check your stackJSON