cve.bz

CVE-2021-27098

8.1 highEPSS 0.6%

High (8.1) in cncf spire. EPSS 0.6% chance of exploitation in the next 30 days. Fixed in github.com/spiffe/spire 0.10.2, 0.11.3, 0.12.1.

In SPIRE 0.8.1 through 0.8.4 and before versions 0.9.4, 0.10.2, 0.11.3 and 0.12.1, specially crafted requests to the FetchX509SVID RPC of SPIRE Server’s Legacy Node API can result in the possible issuance of an X.509 certificate with a URI SAN for a SPIFFE ID that the agent is not authorized to distribute. Proper controls are in place to require that the caller presents a valid agent certificate that is already authorized to issue at least one SPIFFE ID, and the requested SPIFFE ID belongs to the same trust domain, prior to being able to trigger this vulnerability. This issue has been fixed in SPIRE versions 0.8.5, 0.9.4, 0.10.2, 0.11.3 and 0.12.1.

Severity

CVSS 3.1

8.1 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
0.6% chance of exploitation in the next 30 days; higher than 46% of CVEs (scores of 2026-10-31)
CWE
CWE-295
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-h746-rm5q-8mgqGogithub.com/spiffe/spire>=0.8.1 <0.8.50.8.5
GHSA-h746-rm5q-8mgqGogithub.com/spiffe/spire>=0.9.0 <0.9.40.9.4
GHSA-h746-rm5q-8mgqGogithub.com/spiffe/spire>=0.10.0 <0.10.20.10.2
GHSA-h746-rm5q-8mgqGogithub.com/spiffe/spire>=0.11.0 <0.11.30.11.3
GHSA-h746-rm5q-8mgqGogithub.com/spiffe/spire>=0.12.0 <0.12.10.12.1

References

Check your stackJSON