cve.bz

CVE-2021-25974

5.4 mediumEPSS 0.6%

Medium (5.4) in publify project publify. EPSS 0.6% chance of exploitation in the next 30 days. Fixed in publify_core 9.2.5.

In Publify, versions v8.0 to v9.2.4 are vulnerable to stored XSS. A user with a “publisher” role is able to inject and execute arbitrary JavaScript code while creating a page/article.

Severity

CVSS 3.1

5.4 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
0.6% chance of exploitation in the next 30 days; higher than 48% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-wmh9-x28j-c6grRubyGemspublify_core>=8.0 <9.2.59.2.5

References

Check your stackJSON