cve.bz

CVE-2021-23497

9.8 criticalEPSS 3.7%

Critical (9.8) in set project set. EPSS 3.7% chance of exploitation in the next 30 days. Fixed in @strikeentco/set 1.0.2.

This affects the package @strikeentco/set before 1.0.2. It allows an attacker to cause a denial of service and may lead to remote code execution. **Note:** This vulnerability derives from an incomplete fix in https://security.snyk.io/vuln/SNYK-JS-STRIKEENTCOSET-1038821

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
3.7% chance of exploitation in the next 30 days; higher than 89% of CVEs (scores of 2026-10-31)
CWE
CWE-1321
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-39qv-prmh-x37fnpm@strikeentco/set<1.0.21.0.2

References

Check your stackJSON