Critical (9.8) in putil-merge project putil-merge. EPSS 1.3% chance of exploitation in the next 30 days. Fixed in putil-merge 3.8.0.
This affects the package putil-merge before 3.8.0. The merge() function does not check the values passed into the argument. An attacker can supply a malicious value by adjusting the value to include the constructor property. Note: This vulnerability derives from an incomplete fix in https://security.snyk.io/vuln/SNYK-JS-PUTILMERGE-1317077
Severity
CVSS 3.1
9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
1.3% chance of exploitation in the next 30 days; higher than 69% of CVEs (scores of 2026-10-31)