cve.bz

CVE-2021-23440

9.8 criticalEPSS 2.2%

Critical (9.8). EPSS 2.2% chance of exploitation in the next 30 days. Fixed in set-value 2.0.1, 3.0.3, 4.0.1.

This affects the package set-value before <2.0.1, >=3.0.0 <4.0.1. A type confusion vulnerability can lead to a bypass of CVE-2019-10747 when the user-provided keys used in the path parameter are arrays.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
2.2% chance of exploitation in the next 30 days; higher than 82% of CVEs (scores of 2026-10-31)
CWE
CWE-843
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-4jqc-8m5r-9rprnpmset-value>=4.0.0 <4.0.14.0.1
GHSA-4jqc-8m5r-9rprNuGetset-value-nuget<2.0.02.0.0
GHSA-4jqc-8m5r-9rprnpmset-value<2.0.12.0.1
GHSA-4jqc-8m5r-9rprnpmset-value>=3.0.0 <3.0.33.0.3

References

Check your stackJSON