cve.bz

CVE-2021-23406

9.8 criticalEPSS 2.9%

Critical (9.8) in pac-resolver project pac-resolver. EPSS 2.9% chance of exploitation in the next 30 days. Fixed in pac-resolver 5.0.0.

This affects the package pac-resolver before 5.0.0. This can occur when used with untrusted input, due to unsafe PAC file handling. **NOTE:** The fix for this vulnerability is applied in the node-degenerator library, a dependency written by the same maintainer.

Severity

CVSS 3.1

9.8 critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
2.9% chance of exploitation in the next 30 days; higher than 87% of CVEs (scores of 2026-10-31)
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-9j49-mfvp-vmhmnpmpac-resolver<5.0.05.0.0
GHSA-9j49-mfvp-vmhmnpmdegenerator<3.0.13.0.1

References

Check your stackJSON