cve.bz

CVE-2021-23385

6.1 mediumEPSS 1.2%

Medium (6.1) in flask-security project flask-security. EPSS 1.2% chance of exploitation in the next 30 days. Fixed in flask-security 5.5.1.

This affects all versions of package Flask-Security. When using the get_post_logout_redirect and get_post_login_redirect functions, it is possible to bypass URL validation and redirect a user to an arbitrary URL by providing multiple back slashes such as \\\evil.com/path. This vulnerability is only exploitable if an alternative WSGI server other than Werkzeug is used, or the default behaviour of Werkzeug is modified using 'autocorrect_location_header=False. **Note:** Flask-Security is not maintained anymore.

Severity

CVSS 3.1

6.1 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
1.2% chance of exploitation in the next 30 days; higher than 69% of CVEs (scores of 2026-10-31)
CWE
CWE-601
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-cg8c-gc2j-2wf7PyPIflask-security<=3.0.0no fix published
PYSEC-2026-809PyPIflask-security<5.5.15.5.1

References

Check your stackJSON