cve.bz

CVE-2021-21684

6.1 mediumEPSS 1.2%

Medium (6.1) in jenkins git. EPSS 1.2% chance of exploitation in the next 30 days. Fixed in org.jenkins-ci.plugins:git 4.8.3.

Jenkins Git Plugin 4.8.2 and earlier does not escape the Git SHA-1 checksum parameters provided to commit notifications when displaying them in a build cause, resulting in a stored cross-site scripting (XSS) vulnerability.

Severity

CVSS 3.1

6.1 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
1.2% chance of exploitation in the next 30 days; higher than 69% of CVEs (scores of 2026-10-31)
CWE
CWE-116
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-gghc-g8cj-4vfvMavenorg.jenkins-ci.plugins:git<4.8.34.8.3

References

Check your stackJSON