Medium (4.3) in jenkins warnings next generation. EPSS 0.9% chance of exploitation in the next 30 days. Fixed in io.jenkins.plugins:warnings-ng 8.5.0.
Jenkins Warnings Next Generation Plugin 8.4.4 and earlier does not perform a permission check in methods implementing form validation, allowing attackers with Item/Read permission but without Item/Workspace or Item/Configure permission to check whether attacker-specified file patterns match workspace contents.
Severity
CVSS 3.1
4.3 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
EPSS
0.9% chance of exploitation in the next 30 days; higher than 58% of CVEs (scores of 2026-10-31)