cve.bz

CVE-2021-21608

5.4 mediumEPSS 1.0%

Medium (5.4) in jenkins jenkins. EPSS 1.0% chance of exploitation in the next 30 days. Fixed in org.jenkins-ci.main:jenkins-core 2.275.

Jenkins 2.274 and earlier, LTS 2.263.1 and earlier does not escape button labels in the Jenkins UI, resulting in a cross-site scripting (XSS) vulnerability exploitable by attackers with the ability to control button labels.

Severity

CVSS 3.1

5.4 medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
1.0% chance of exploitation in the next 30 days; higher than 64% of CVEs (scores of 2026-10-31)
CWE
CWE-79
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-wv63-gwr9-5c55Mavenorg.jenkins-ci.main:jenkins-core<2.2752.275
GHSA-wv63-gwr9-5c55Mavenorg.jenkins-ci.main:jenkins-core>=2.263.2 <2.2752.275

References

Check your stackJSON