cve.bz

CVE-2021-21605

8.0 highEPSS 2.2%

High (8.0) in jenkins jenkins. EPSS 2.2% chance of exploitation in the next 30 days. Fixed in org.jenkins-ci.main:jenkins-core 2.263.2, 2.275.

Jenkins 2.274 and earlier, LTS 2.263.1 and earlier allows users with Agent/Configure permission to choose agent names that cause Jenkins to override the global `config.xml` file.

Severity

CVSS 3.1

8.0 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
EPSS
2.2% chance of exploitation in the next 30 days; higher than 82% of CVEs (scores of 2026-10-31)
CWE
CWE-22
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-pxgq-gqr9-5gwxMavenorg.jenkins-ci.main:jenkins-core<2.263.22.263.2
GHSA-pxgq-gqr9-5gwxMavenorg.jenkins-ci.main:jenkins-core>=2.264 <2.2752.275

References

Check your stackJSON