cve.bz

CVE-2021-21409

5.9 mediumEPSS 4.9%

Netty is an open-source, asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In Netty (io.netty:netty-codec-http2) before version 4.1.61.Final there is a vulnerability that enables request smuggling. The content-length header is not correctly validated if the request only uses a single Http2HeaderFrame with the endStream set to to true. This could lead to request smuggling if the request is proxied to a remote peer and translated to HTTP/1.1. This is a followup of GHSA-wm47-8v5p-wjpj/CVE-2021-21295 which did miss to fix this one case. This was fixed as part of 4.1.61.Final.

CVSS 3.1
5.9CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
4.9% chance of exploitation in the next 30 days; higher than 92% of CVEs (scores of 2026-10-25)
CWE
CWE-444
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-f256-j965-7f32Mavenio.netty:netty-codec-http2>=4.0.0 <4.1.61.Final4.1.61.Final
GHSA-f256-j965-7f32Mavenorg.jboss.netty:nettyall versionsno fix published
GHSA-f256-j965-7f32Mavenio.netty:nettyall versionsno fix published

References

Check your stackJSON