cve.bz

CVE-2021-21391

6.5 mediumEPSS 1.7%

Medium (6.5) in ckeditor. EPSS 1.7% chance of exploitation in the next 30 days. Fixed in @ckeditor/ckeditor5-engine 27.0.0.

CKEditor 5 provides a WYSIWYG editing solution. This CVE affects the following npm packages: ckeditor5-engine, ckeditor5-font, ckeditor5-image, ckeditor5-list, ckeditor5-markdown-gfm, ckeditor5-media-embed, ckeditor5-paste-from-office, and ckeditor5-widget. Following an internal audit, a regular expression denial of service (ReDoS) vulnerability has been discovered in multiple CKEditor 5 packages. The vulnerability allowed to abuse particular regular expressions, which could cause a significant performance drop resulting in a browser tab freeze. It affects all users using the CKEditor 5 packages listed above at version <= 26.0.0. The problem has been recognized and patched. The fix will be available in version 27.0.0.

Severity

CVSS 3.1

6.5 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
EPSS
1.7% chance of exploitation in the next 30 days; higher than 76% of CVEs (scores of 2026-10-31)
CWE
CWE-400
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-3rh3-wfr4-76mjnpm@ckeditor/ckeditor5-engine<27.0.027.0.0
GHSA-3rh3-wfr4-76mjnpm@ckeditor/ckeditor5-font<27.0.027.0.0
GHSA-3rh3-wfr4-76mjnpm@ckeditor/ckeditor5-image<27.0.027.0.0
GHSA-3rh3-wfr4-76mjnpm@ckeditor/ckeditor5-list<27.0.027.0.0
GHSA-3rh3-wfr4-76mjnpm@ckeditor/ckeditor5-markdown-gfm<27.0.027.0.0
GHSA-3rh3-wfr4-76mjnpm@ckeditor/ckeditor5-media-embed<27.0.027.0.0
GHSA-3rh3-wfr4-76mjnpm@ckeditor/ckeditor5-paste-from-office<27.0.027.0.0
GHSA-3rh3-wfr4-76mjnpm@ckeditor/ckeditor5-widget<27.0.027.0.0

References

Check your stackJSON