cve.bz

CVE-2021-21305

8.8 highEPSS 13%

High (8.8) in carrierwave project carrierwave. EPSS 13% chance of exploitation in the next 30 days. Fixed in carrierwave 1.3.2, 2.1.1.

CarrierWave is an open-source RubyGem which provides a simple and flexible way to upload files from Ruby applications. In CarrierWave before versions 1.3.2 and 2.1.1, there is a code injection vulnerability. The "#manipulate!" method inappropriately evals the content of mutation option(:read/:write), allowing attackers to craft a string that can be executed as a Ruby code. If an application developer supplies untrusted inputs to the option, it will lead to remote code execution(RCE). This is fixed in versions 1.3.2 and 2.1.1.

Severity

CVSS 3.1

8.8 high
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
13% chance of exploitation in the next 30 days; higher than 96% of CVEs (scores of 2026-10-31)
CWEs
CWE-94, CWE-74
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-cf3w-g86h-35x4RubyGemscarrierwave<1.3.21.3.2
GHSA-cf3w-g86h-35x4RubyGemscarrierwave>=2.0.0 <2.1.12.1.1

References

Check your stackJSON