cve.bz

CVE-2021-20188

7.0 highEPSS 0.3%

High (7.0). EPSS 0.3% chance of exploitation in the next 30 days. Fixed in github.com/containers/libpod 1.7.0.

A flaw was found in podman before 1.7.0. File permissions for non-root users running in a privileged container are not correctly checked. This flaw can be abused by a low-privileged user inside the container to access any other file in the container, even if owned by the root user inside the container. It does not allow to directly escape the container, though being a privileged container means that a lot of security features are disabled when running the container. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Severity

CVSS 3.1

7.0 high
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
0.3% chance of exploitation in the next 30 days; higher than 17% of CVEs (scores of 2026-10-31)
CWE
CWE-863
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-9h63-7qf6-mv6rGogithub.com/containers/libpod<1.7.01.7.0
GO-2022-0641Gogithub.com/containers/libpod<1.7.01.7.0

References

Check your stackJSON