cve.bz

CVE-2020-8244

6.5 mediumEPSS 2.1%

Medium (6.5). EPSS 2.1% chance of exploitation in the next 30 days. Fixed in bl 1.2.3, 2.2.1, 3.0.1.

A buffer over-read vulnerability exists in bl <4.0.3, <3.0.1, <2.2.1, and <1.2.3 which could allow an attacker to supply user input (even typed) that if it ends up in consume() argument and can become negative, the BufferList state can be corrupted, tricking it into exposing uninitialized memory via regular .slice() calls.

Severity

CVSS 3.1

6.5 medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
EPSS
2.1% chance of exploitation in the next 30 days; higher than 81% of CVEs (scores of 2026-10-31)
CWEs
CWE-125, CWE-126
Published
Modified
Record from
the NVD, synced

Affected

Packages (OSV)

AdvisoryEcosystemPackageAffectedFixed in
GHSA-pp7h-53gx-mx7rnpmbl<1.2.31.2.3
GHSA-pp7h-53gx-mx7rnpmbl>=2.0.0 <2.2.12.2.1
GHSA-pp7h-53gx-mx7rnpmbl>=3.0.0 <3.0.13.0.1
GHSA-pp7h-53gx-mx7rnpmbl>=4.0.0 <4.0.34.0.3

References

Check your stackJSON